Introduction

The purpose of this help file is to provide Modbus address and register map for the following series:

r ioLogik E1500 Series


Supported Function Code

Register (decimal) | Access | Type | Supported Function Code
0xxxx | R/W | bit | 1, 5, 15
1xxxx | R | bit | 2
3xxxx | R | word | 4
4xxxx | R/W | word | 3, 6, 16


ioLogik E1510 Modbus Address and Register Map

Address (hex) | Register (decimal) | Access | Type | Parameter Name | Description
0x0100 | 00257 | R/W | bit | DI-00_counterStatus | 0: STOP, 1: START
0x0101 | 00258 | R/W | bit | DI-01_counterStatus | 0: STOP, 1: START
0x0102 | 00259 | R/W | bit | DI-02_counterStatus | 0: STOP, 1: START
0x0103 | 00260 | R/W | bit | DI-03_counterStatus | 0: STOP, 1: START
0x0104 | 00261 | R/W | bit | DI-04_counterStatus | 0: STOP, 1: START
0x0105 | 00262 | R/W | bit | DI-05_counterStatus | 0: STOP, 1: START
0x0106 | 00263 | R/W | bit | DI-06_counterStatus | 0: STOP, 1: START
0x0107 | 00264 | R/W | bit | DI-07_counterStatus | 0: STOP, 1: START
0x0108 | 00265 | R/W | bit | DI-08_counterStatus | 0: STOP, 1: START
0x0109 | 00266 | R/W | bit | DI-09_counterStatus | 0: STOP, 1: START
0x010A | 00267 | R/W | bit | DI-10_counterStatus | 0: STOP, 1: START
0x010B | 00268 | R/W | bit | DI-11_counterStatus | 0: STOP, 1: START
0x0110 | 00273 | R/W | bit | DI-00_counterReset | 1: reset to initial value
0x0111 | 00274 | R/W | bit | DI-01_counterReset | 1: reset to initial value
0x0112 | 00275 | R/W | bit | DI-02_counterReset | 1: reset to initial value
0x0113 | 00276 | R/W | bit | DI-03_counterReset | 1: reset to initial value
0x0114 | 00277 | R/W | bit | DI-04_counterReset | 1: reset to initial value
0x0115 | 00278 | R/W | bit | DI-05_counterReset | 1: reset to initial value
0x0116 | 00279 | R/W | bit | DI-06_counterReset | 1: reset to initial value
0x0117 | 00280 | R/W | bit | DI-07_counterReset | 1: reset to initial value
0x0118 | 00281 | R/W | bit | DI-08_counterReset | 1: reset to initial value
0x0119 | 00282 | R/W | bit | DI-09_counterReset | 1: reset to initial value
0x011A | 00283 | R/W | bit | DI-10_counterReset | 1: reset to initial value
0x011B | 00284 | R/W | bit | DI-11_counterReset | 1: reset to initial value
0x0000 | 10001 | R | bit | DI-00_status | 0: OFF, 1: ON
0x0001 | 10002 | R | bit | DI-01_status | 0: OFF, 1: ON
0x0002 | 10003 | R | bit | DI-02_status | 0: OFF, 1: ON
0x0003 | 10004 | R | bit | DI-03_status | 0: OFF, 1: ON
0x0004 | 10005 | R | bit | DI-04_status | 0: OFF, 1: ON
0x0005 | 10006 | R | bit | DI-05_status | 0: OFF, 1: ON
0x0006 | 10007 | R | bit | DI-06_status | 0: OFF, 1: ON
0x0007 | 10008 | R | bit | DI-07_status | 0: OFF, 1: ON
0x0008 | 10009 | R | bit | DI-08_status | 0: OFF, 1: ON
0x0009 | 10010 | R | bit | DI-09_status | 0: OFF, 1: ON
0x000A | 10011 | R | bit | DI-10_status | 0: OFF, 1: ON
0x000B | 10012 | R | bit | DI-11_status | 0: OFF, 1: ON
0x0000 | 30001 | R | word | DI-00_status | 0: OFF, 1: ON
0x0001 | 30002 | R | word | DI-01_status | 0: OFF, 1: ON
0x0002 | 30003 | R | word | DI-02_status | 0: OFF, 1: ON
0x0003 | 30004 | R | word | DI-03_status | 0: OFF, 1: ON
0x0004 | 30005 | R | word | DI-04_status | 0: OFF, 1: ON
0x0005 | 30006 | R | word | DI-05_status | 0: OFF, 1: ON
0x0006 | 30007 | R | word | DI-06_status | 0: OFF, 1: ON
0x0007 | 30008 | R | word | DI-07_status | 0: OFF, 1: ON
0x0008 | 30009 | R | word | DI-08_status | 0: OFF, 1: ON
0x0009 | 30010 | R | word | DI-09_status | 0: OFF, 1: ON
0x000A | 30011 | R | word | DI-10_status | 0: OFF, 1: ON
0x000B | 30012 | R | word | DI-11_status | 0: OFF, 1: ON
0x0010 | 30017 | R | word | DI-00_counterValueHigh | high word
0x0011 | 30018 | R | word | DI-00_counterValueLow | low word
0x0012 | 30019 | R | word | DI-01_counterValueHigh | high word
0x0013 | 30020 | R | word | DI-01_counterValueLow | low word
0x0014 | 30021 | R | word | DI-02_counterValueHigh | high word
0x0015 | 30022 | R | word | DI-02_counterValueLow | low word
0x0016 | 30023 | R | word | DI-03_counterValueHigh | high word
0x0017 | 30024 | R | word | DI-03_counterValueLow | low word
0x0018 | 30025 | R | word | DI-04_counterValueHigh | high word
0x0019 | 30026 | R | word | DI-04_counterValueLow | low word
0x001A | 30027 | R | word | DI-05_counterValueHigh | high word
0x001B | 30028 | R | word | DI-05_counterValueLow | low word
0x001C | 30029 | R | word | DI-06_counterValueHigh | high word
0x001D | 30030 | R | word | DI-06_counterValueLow | low word
0x001E | 30031 | R | word | DI-07_counterValueHigh | high word
0x001F | 30032 | R | word | DI-07_counterValueLow | low word
0x0020 | 30033 | R | word | DI-08_counterValueHigh | high word
0x0021 | 30034 | R | word | DI-08_counterValueLow | low word
0x0022 | 30035 | R | word | DI-09_counterValueHigh | high word
0x0023 | 30036 | R | word | DI-09_counterValueLow | low word
0x0024 | 30037 | R | word | DI-10_counterValueHigh | high word
0x0025 | 30038 | R | word | DI-10_counterValueLow | low word
0x0026 | 30039 | R | word | DI-11_counterValueHigh | high word
0x0027 | 30040 | R | word | DI-11_counterValueLow | low word
0x0030 | 30049 | R | word | DI-all_statusFromDI-00 | 0: OFF, 1: ON
0x0100 | 40257 | R/W | word | DI-00_counterStatus | 0: STOP, 1: START
0x0101 | 40258 | R/W | word | DI-01_counterStatus | 0: STOP, 1: START
0x0102 | 40259 | R/W | word | DI-02_counterStatus | 0: STOP, 1: START
0x0103 | 40260 | R/W | word | DI-03_counterStatus | 0: STOP, 1: START
0x0104 | 40261 | R/W | word | DI-04_counterStatus | 0: STOP, 1: START
0x0105 | 40262 | R/W | word | DI-05_counterStatus | 0: STOP, 1: START
0x0106 | 40263 | R/W | word | DI-06_counterStatus | 0: STOP, 1: START
0x0107 | 40264 | R/W | word | DI-07_counterStatus | 0: STOP, 1: START
0x0108 | 40265 | R/W | word | DI-08_counterStatus | 0: STOP, 1: START
0x0109 | 40266 | R/W | word | DI-09_counterStatus | 0: STOP, 1: START
0x010A | 40267 | R/W | word | DI-10_counterStatus | 0: STOP, 1: START
0x010B | 40268 | R/W | word | DI-11_counterStatus | 0: STOP, 1: START
0x0110 | 40273 | R/W | word | DI-00_counterReset | 1: reset to initial value
0x0111 | 40274 | R/W | word | DI-01_counterReset | 1: reset to initial value
0x0112 | 40275 | R/W | word | DI-02_counterReset | 1: reset to initial value
0x0113 | 40276 | R/W | word | DI-03_counterReset | 1: reset to initial value
0x0114 | 40277 | R/W | word | DI-04_counterReset | 1: reset to initial value
0x0115 | 40278 | R/W | word | DI-05_counterReset | 1: reset to initial value
0x0116 | 40279 | R/W | word | DI-06_counterReset | 1: reset to initial value
0x0117 | 40280 | R/W | word | DI-07_counterReset | 1: reset to initial value
0x0118 | 40281 | R/W | word | DI-08_counterReset | 1: reset to initial value
0x0119 | 40282 | R/W | word | DI-09_counterReset | 1: reset to initial value
0x011A | 40283 | R/W | word | DI-10_counterReset | 1: reset to initial value
0x011B | 40284 | R/W | word | DI-11_counterReset | 1: reset to initial value


ioLogik E1512 Modbus Address and Register Map

Address (hex) | Register (decimal) | Access | Type | Parameter Name | Description
0x0000 | 00001 | R/W | bit | DO-00_status | 0: OFF, 1: ON
0x0001 | 00002 | R/W | bit | DO-01_status | 0: OFF, 1: ON
0x0002 | 00003 | R/W | bit | DO-02_status | 0: OFF, 1: ON
0x0003 | 00004 | R/W | bit | DO-03_status | 0: OFF, 1: ON
0x0010 | 00017 | R/W | bit | DO-00_pulseStatus | 0: STOP, 1: START
0x0011 | 00018 | R/W | bit | DO-01_pulseStatus | 0: STOP, 1: START
0x0012 | 00019 | R/W | bit | DO-02_pulseStatus | 0: STOP, 1: START
0x0013 | 00020 | R/W | bit | DO-03_pulseStatus | 0: STOP, 1: START
0x0100 | 00257 | R/W | bit | DI-00_counterStatus | 0: STOP, 1: START
0x0101 | 00258 | R/W | bit | DI-01_counterStatus | 0: STOP, 1: START
0x0102 | 00259 | R/W | bit | DI-02_counterStatus | 0: STOP, 1: START
0x0103 | 00260 | R/W | bit | DI-03_counterStatus | 0: STOP, 1: START
0x0104 | 00261 | R/W | bit | DI-04_counterStatus | 0: STOP, 1: START
0x0105 | 00262 | R/W | bit | DI-05_counterStatus | 0: STOP, 1: START
0x0106 | 00263 | R/W | bit | DI-06_counterStatus | 0: STOP, 1: START
0x0107 | 00264 | R/W | bit | DI-07_counterStatus | 0: STOP, 1: START
0x0110 | 00273 | R/W | bit | DI-00_counterReset | 1: reset to initial value
0x0111 | 00274 | R/W | bit | DI-01_counterReset | 1: reset to initial value
0x0112 | 00275 | R/W | bit | DI-02_counterReset | 1: reset to initial value
0x0113 | 00276 | R/W | bit | DI-03_counterReset | 1: reset to initial value
0x0114 | 00277 | R/W | bit | DI-04_counterReset | 1: reset to initial value
0x0115 | 00278 | R/W | bit | DI-05_counterReset | 1: reset to initial value
0x0116 | 00279 | R/W | bit | DI-06_counterReset | 1: reset to initial value
0x0117 | 00280 | R/W | bit | DI-07_counterReset | 1: reset to initial value
0x0000 | 10001 | R | bit | DI-00_status | 0: OFF, 1: ON
0x0001 | 10002 | R | bit | DI-01_status | 0: OFF, 1: ON
0x0002 | 10003 | R | bit | DI-02_status | 0: OFF, 1: ON
0x0003 | 10004 | R | bit | DI-03_status | 0: OFF, 1: ON
0x0004 | 10005 | R | bit | DI-04_status | 0: OFF, 1: ON
0x0005 | 10006 | R | bit | DI-05_status | 0: OFF, 1: ON
0x0006 | 10007 | R | bit | DI-06_status | 0: OFF, 1: ON
0x0007 | 10008 | R | bit | DI-07_status | 0: OFF, 1: ON
0x0000 | 30001 | R | word | DI-00_status | 0: OFF, 1: ON
0x0001 | 30002 | R | word | DI-01_status | 0: OFF, 1: ON
0x0002 | 30003 | R | word | DI-02_status | 0: OFF, 1: ON
0x0003 | 30004 | R | word | DI-03_status | 0: OFF, 1: ON
0x0004 | 30005 | R | word | DI-04_status | 0: OFF, 1: ON
0x0005 | 30006 | R | word | DI-05_status | 0: OFF, 1: ON
0x0006 | 30007 | R | word | DI-06_status | 0: OFF, 1: ON
0x0007 | 30008 | R | word | DI-07_status | 0: OFF, 1: ON
0x0010 | 30017 | R | word | DI-00_counterValueHigh | high word
0x0011 | 30018 | R | word | DI-00_counterValueLow | low word
0x0012 | 30019 | R | word | DI-01_counterValueHigh | high word
0x0013 | 30020 | R | word | DI-01_counterValueLow | low word
0x0014 | 30021 | R | word | DI-02_counterValueHigh | high word
0x0015 | 30022 | R | word | DI-02_counterValueLow | low word
0x0016 | 30023 | R | word | DI-03_counterValueHigh | high word
0x0017 | 30024 | R | word | DI-03_counterValueLow | low word
0x0018 | 30025 | R | word | DI-04_counterValueHigh | high word
0x0019 | 30026 | R | word | DI-04_counterValueLow | low word
0x001A | 30027 | R | word | DI-05_counterValueHigh | high word
0x001B | 30028 | R | word | DI-05_counterValueLow | low word
0x001C | 30029 | R | word | DI-06_counterValueHigh | high word
0x001D | 30030 | R | word | DI-06_counterValueLow | low word
0x001E | 30031 | R | word | DI-07_counterValueHigh | high word
0x001F | 30032 | R | word | DI-07_counterValueLow | low word
0x0030 | 30049 | R | word | DI-all_statusFromDI-00 | 0: OFF, 1: ON
0x0000 | 40001 | R/W | word | DO-00_status | 0: OFF, 1: ON
0x0001 | 40002 | R/W | word | DO-01_status | 0: OFF, 1: ON
0x0002 | 40003 | R/W | word | DO-02_status | 0: OFF, 1: ON
0x0003 | 40004 | R/W | word | DO-03_status | 0: OFF, 1: ON
0x0010 | 40017 | R/W | word | DO-00_pulseStatus | 0: STOP, 1: START
0x0011 | 40018 | R/W | word | DO-01_pulseStatus | 0: STOP, 1: START
0x0012 | 40019 | R/W | word | DO-02_pulseStatus | 0: STOP, 1: START
0x0013 | 40020 | R/W | word | DO-03_pulseStatus | 0: STOP, 1: START
0x0020 | 40033 | R/W | word | DO-all_statusFromDO-00 | 0: OFF, 1: ON
0x0100 | 40257 | R/W | word | DI-00_counterStatus | 0: STOP, 1: START
0x0101 | 40258 | R/W | word | DI-01_counterStatus | 0: STOP, 1: START
0x0102 | 40259 | R/W | word | DI-02_counterStatus | 0: STOP, 1: START
0x0103 | 40260 | R/W | word | DI-03_counterStatus | 0: STOP, 1: START
0x0104 | 40261 | R/W | word | DI-04_counterStatus | 0: STOP, 1: START
0x0105 | 40262 | R/W | word | DI-05_counterStatus | 0: STOP, 1: START
0x0106 | 40263 | R/W | word | DI-06_counterStatus | 0: STOP, 1: START
0x0107 | 40264 | R/W | word | DI-07_counterStatus | 0: STOP, 1: START
0x0110 | 40273 | R/W | word | DI-00_counterReset | 1: reset to initial value
0x0111 | 40274 | R/W | word | DI-01_counterReset | 1: reset to initial value
0x0112 | 40275 | R/W | word | DI-02_counterReset | 1: reset to initial value
0x0113 | 40276 | R/W | word | DI-03_counterReset | 1: reset to initial value
0x0114 | 40277 | R/W | word | DI-04_counterReset | 1: reset to initial value
0x0115 | 40278 | R/W | word | DI-05_counterReset | 1: reset to initial value
0x0116 | 40279 | R/W | word | DI-06_counterReset | 1: reset to initial value
0x0117 | 40280 | R/W | word | DI-07_counterReset | 1: reset to initial value