Introduction

The purpose of this help file is to provide Modbus address and register map for the following series:

r ioLogik R1200 Series


Supported Function Code

Register (decimal) | Access | Type | Supported Function Code
0xxxx | R/W | bit | 1, 5, 15
1xxxx | R | bit | 2
3xxxx | R | word | 4
4xxxx | R/W | word | 3, 6, 16


ioLogik R1200 System Modbus Address and Register Map

Address (hex) | Register (decimal) | Access | Type | Parameter Name | Description
0x7530 | 330001 | R | word | modelID |
0x7545 | 330022 | R | word | firmwareVersion | 2 words
0x7547 | 330024 | R | word | firmwareReleaseDate | 2 words
0x7549 | 330026 | R | word | vendorID |
0x754A | 330027 | R | word | unitID |
0x754B | 330028 | R | word | serialNumber | 6 words
0x7555 | 330038 | R | word | productName | 10 words
0x756A | 330059 | R | word | rs485PortMode | 0: initial-repeater, 1: initial-dual RS-485, 2: run-repeater, 3: run-dual RS-485
0x7531 | 430002 | R/W | word | serverName | 10 words
0x753B | 430012 | R/W | word | serverLocation | 10 words
0x755F | 430048 | R/W | word | password | 5 words
0x7564 | 430053 | R/W | word | modbusWatchdogFuntion | 0: Disable, 1: Enable
0x7565 | 430054 | R/W | word | modbusWatchdogTimeout | unit: sec(s)
0x7566 | 430055 | R/W | word | modbusWatchdogStatus | 0: Normal, 1: Timeout
0x7567 | 430056 | R/W | word | locateDevice |
0x7568 | 430057 | R/W | word | restartDevice | 404: Enable
0x7569 | 430058 | R/W | word | loadFactoryDefault | 404: Enable
0x756C | 430061 | R/W | word | port0Baudrate | 1: 1200, 2: 2400, 3: 4800, 4: 9600, 5: 19200, 6: 38400, 7: 57600, 8: 115200, 9: 921600
0x756D | 430062 | R/W | word | port1Baudrate | 1: 1200, 2: 2400, 3: 4800, 4: 9600, 5: 19200, 6: 38400, 7: 57600, 8: 115200, 9: 921600
0x7570 | 430065 | R/W | word | port0StopBit | 0: 1, 1: 2
0x7571 | 430066 | R/W | word | port1StopBit | 0: 1, 1: 2
0x7572 | 430067 | R/W | word | port0Parity | 0: None, 1: Even, 2: Odd
0x7573 | 430068 | R/W | word | port1Parity | 0: None, 1: Even, 2: Odd
0x7594 | 430101 | R/W | word | vendorName | 20 words


ioLogik R1210 Modbus Address and Register Map

Address (hex) | Register (decimal) | Access | Type | Parameter Name | Description
0x0000 | 00001 | R/W | bit | DI-00_counterStatus | 0: STOP, 1: START
0x0001 | 00002 | R/W | bit | DI-01_counterStatus | 0: STOP, 1: START
0x0002 | 00003 | R/W | bit | DI-02_counterStatus | 0: STOP, 1: START
0x0003 | 00004 | R/W | bit | DI-03_counterStatus | 0: STOP, 1: START
0x0004 | 00005 | R/W | bit | DI-04_counterStatus | 0: STOP, 1: START
0x0005 | 00006 | R/W | bit | DI-05_counterStatus | 0: STOP, 1: START
0x0006 | 00007 | R/W | bit | DI-06_counterStatus | 0: STOP, 1: START
0x0007 | 00008 | R/W | bit | DI-07_counterStatus | 0: STOP, 1: START
0x0008 | 00009 | R/W | bit | DI-08_counterStatus | 0: STOP, 1: START
0x0009 | 00010 | R/W | bit | DI-09_counterStatus | 0: STOP, 1: START
0x000A | 00011 | R/W | bit | DI-10_counterStatus | 0: STOP, 1: START
0x000B | 00012 | R/W | bit | DI-11_counterStatus | 0: STOP, 1: START
0x000C | 00013 | R/W | bit | DI-12_counterStatus | 0: STOP, 1: START
0x000D | 00014 | R/W | bit | DI-13_counterStatus | 0: STOP, 1: START
0x000E | 00015 | R/W | bit | DI-14_counterStatus | 0: STOP, 1: START
0x000F | 00016 | R/W | bit | DI-15_counterStatus | 0: STOP, 1: START
0x0020 | 00033 | R/W | bit | DI-00_counterReset | 1: reset to initial value
0x0021 | 00034 | R/W | bit | DI-01_counterReset | 1: reset to initial value
0x0022 | 00035 | R/W | bit | DI-02_counterReset | 1: reset to initial value
0x0023 | 00036 | R/W | bit | DI-03_counterReset | 1: reset to initial value
0x0024 | 00037 | R/W | bit | DI-04_counterReset | 1: reset to initial value
0x0025 | 00038 | R/W | bit | DI-05_counterReset | 1: reset to initial value
0x0026 | 00039 | R/W | bit | DI-06_counterReset | 1: reset to initial value
0x0027 | 00040 | R/W | bit | DI-07_counterReset | 1: reset to initial value
0x0028 | 00041 | R/W | bit | DI-08_counterReset | 1: reset to initial value
0x0029 | 00042 | R/W | bit | DI-09_counterReset | 1: reset to initial value
0x002A | 00043 | R/W | bit | DI-10_counterReset | 1: reset to initial value
0x002B | 00044 | R/W | bit | DI-11_counterReset | 1: reset to initial value
0x002C | 00045 | R/W | bit | DI-12_counterReset | 1: reset to initial value
0x002D | 00046 | R/W | bit | DI-13_counterReset | 1: reset to initial value
0x002E | 00047 | R/W | bit | DI-14_counterReset | 1: reset to initial value
0x002F | 00048 | R/W | bit | DI-15_counterReset | 1: reset to initial value
0x0040 | 00065 | R/W | bit | DI-00_counterOverflowFlag | 1: clear overflow flag
0x0041 | 00066 | R/W | bit | DI-01_counterOverflowFlag | 1: clear overflow flag
0x0042 | 00067 | R/W | bit | DI-02_counterOverflowFlag | 1: clear overflow flag
0x0043 | 00068 | R/W | bit | DI-03_counterOverflowFlag | 1: clear overflow flag
0x0044 | 00069 | R/W | bit | DI-04_counterOverflowFlag | 1: clear overflow flag
0x0045 | 00070 | R/W | bit | DI-05_counterOverflowFlag | 1: clear overflow flag
0x0046 | 00071 | R/W | bit | DI-06_counterOverflowFlag | 1: clear overflow flag
0x0047 | 00072 | R/W | bit | DI-07_counterOverflowFlag | 1: clear overflow flag
0x0048 | 00073 | R/W | bit | DI-08_counterOverflowFlag | 1: clear overflow flag
0x0049 | 00074 | R/W | bit | DI-09_counterOverflowFlag | 1: clear overflow flag
0x004A | 00075 | R/W | bit | DI-10_counterOverflowFlag | 1: clear overflow flag
0x004B | 00076 | R/W | bit | DI-11_counterOverflowFlag | 1: clear overflow flag
0x004C | 00077 | R/W | bit | DI-12_counterOverflowFlag | 1: clear overflow flag
0x004D | 00078 | R/W | bit | DI-13_counterOverflowFlag | 1: clear overflow flag
0x004E | 00079 | R/W | bit | DI-14_counterOverflowFlag | 1: clear overflow flag
0x004F | 00080 | R/W | bit | DI-15_counterOverflowFlag | 1: clear overflow flag
0x0060 | 00097 | R/W | bit | DI-00_counterPowerOnStatus | 0: STOP, 1: START
0x0061 | 00098 | R/W | bit | DI-01_counterPowerOnStatus | 0: STOP, 1: START
0x0062 | 00099 | R/W | bit | DI-02_counterPowerOnStatus | 0: STOP, 1: START
0x0063 | 00100 | R/W | bit | DI-03_counterPowerOnStatus | 0: STOP, 1: START
0x0064 | 00101 | R/W | bit | DI-04_counterPowerOnStatus | 0: STOP, 1: START
0x0065 | 00102 | R/W | bit | DI-05_counterPowerOnStatus | 0: STOP, 1: START
0x0066 | 00103 | R/W | bit | DI-06_counterPowerOnStatus | 0: STOP, 1: START
0x0067 | 00104 | R/W | bit | DI-07_counterPowerOnStatus | 0: STOP, 1: START
0x0068 | 00105 | R/W | bit | DI-08_counterPowerOnStatus | 0: STOP, 1: START
0x0069 | 00106 | R/W | bit | DI-09_counterPowerOnStatus | 0: STOP, 1: START
0x006A | 00107 | R/W | bit | DI-10_counterPowerOnStatus | 0: STOP, 1: START
0x006B | 00108 | R/W | bit | DI-11_counterPowerOnStatus | 0: STOP, 1: START
0x006C | 00109 | R/W | bit | DI-12_counterPowerOnStatus | 0: STOP, 1: START
0x006D | 00110 | R/W | bit | DI-13_counterPowerOnStatus | 0: STOP, 1: START
0x006E | 00111 | R/W | bit | DI-14_counterPowerOnStatus | 0: STOP, 1: START
0x006F | 00112 | R/W | bit | DI-15_counterPowerOnStatus | 0: STOP, 1: START
0x0080 | 00129 | R/W | bit | DI-00_counterSafeModeStatus | 0: STOP, 1: START
0x0081 | 00130 | R/W | bit | DI-01_counterSafeModeStatus | 0: STOP, 1: START
0x0082 | 00131 | R/W | bit | DI-02_counterSafeModeStatus | 0: STOP, 1: START
0x0083 | 00132 | R/W | bit | DI-03_counterSafeModeStatus | 0: STOP, 1: START
0x0084 | 00133 | R/W | bit | DI-04_counterSafeModeStatus | 0: STOP, 1: START
0x0085 | 00134 | R/W | bit | DI-05_counterSafeModeStatus | 0: STOP, 1: START
0x0086 | 00135 | R/W | bit | DI-06_counterSafeModeStatus | 0: STOP, 1: START
0x0087 | 00136 | R/W | bit | DI-07_counterSafeModeStatus | 0: STOP, 1: START
0x0088 | 00137 | R/W | bit | DI-08_counterSafeModeStatus | 0: STOP, 1: START
0x0089 | 00138 | R/W | bit | DI-09_counterSafeModeStatus | 0: STOP, 1: START
0x008A | 00139 | R/W | bit | DI-10_counterSafeModeStatus | 0: STOP, 1: START
0x008B | 00140 | R/W | bit | DI-11_counterSafeModeStatus | 0: STOP, 1: START
0x008C | 00141 | R/W | bit | DI-12_counterSafeModeStatus | 0: STOP, 1: START
0x008D | 00142 | R/W | bit | DI-13_counterSafeModeStatus | 0: STOP, 1: START
0x008E | 00143 | R/W | bit | DI-14_counterSafeModeStatus | 0: STOP, 1: START
0x008F | 00144 | R/W | bit | DI-15_counterSafeModeStatus | 0: STOP, 1: START
0x00A0 | 00161 | R/W | bit | DI-00_counterPowerOffStorage | 0: Disable, 1: Enable
0x00A1 | 00162 | R/W | bit | DI-01_counterPowerOffStorage | 0: Disable, 1: Enable
0x00A2 | 00163 | R/W | bit | DI-02_counterPowerOffStorage | 0: Disable, 1: Enable
0x00A3 | 00164 | R/W | bit | DI-03_counterPowerOffStorage | 0: Disable, 1: Enable
0x00A4 | 00165 | R/W | bit | DI-04_counterPowerOffStorage | 0: Disable, 1: Enable
0x00A5 | 00166 | R/W | bit | DI-05_counterPowerOffStorage | 0: Disable, 1: Enable
0x00A6 | 00167 | R/W | bit | DI-06_counterPowerOffStorage | 0: Disable, 1: Enable
0x00A7 | 00168 | R/W | bit | DI-07_counterPowerOffStorage | 0: Disable, 1: Enable
0x00A8 | 00169 | R/W | bit | DI-08_counterPowerOffStorage | 0: Disable, 1: Enable
0x00A9 | 00170 | R/W | bit | DI-09_counterPowerOffStorage | 0: Disable, 1: Enable
0x00AA | 00171 | R/W | bit | DI-10_counterPowerOffStorage | 0: Disable, 1: Enable
0x00AB | 00172 | R/W | bit | DI-11_counterPowerOffStorage | 0: Disable, 1: Enable
0x00AC | 00173 | R/W | bit | DI-12_counterPowerOffStorage | 0: Disable, 1: Enable
0x00AD | 00174 | R/W | bit | DI-13_counterPowerOffStorage | 0: Disable, 1: Enable
0x00AE | 00175 | R/W | bit | DI-14_counterPowerOffStorage | 0: Disable, 1: Enable
0x00AF | 00176 | R/W | bit | DI-15_counterPowerOffStorage | 0: Disable, 1: Enable
0x0000 | 10001 | R | bit | DI-00_status | 0: OFF, 1: ON
0x0001 | 10002 | R | bit | DI-01_status | 0: OFF, 1: ON
0x0002 | 10003 | R | bit | DI-02_status | 0: OFF, 1: ON
0x0003 | 10004 | R | bit | DI-03_status | 0: OFF, 1: ON
0x0004 | 10005 | R | bit | DI-04_status | 0: OFF, 1: ON
0x0005 | 10006 | R | bit | DI-05_status | 0: OFF, 1: ON
0x0006 | 10007 | R | bit | DI-06_status | 0: OFF, 1: ON
0x0007 | 10008 | R | bit | DI-07_status | 0: OFF, 1: ON
0x0008 | 10009 | R | bit | DI-08_status | 0: OFF, 1: ON
0x0009 | 10010 | R | bit | DI-09_status | 0: OFF, 1: ON
0x000A | 10011 | R | bit | DI-10_status | 0: OFF, 1: ON
0x000B | 10012 | R | bit | DI-11_status | 0: OFF, 1: ON
0x000C | 10013 | R | bit | DI-12_status | 0: OFF, 1: ON
0x000D | 10014 | R | bit | DI-13_status | 0: OFF, 1: ON
0x000E | 10015 | R | bit | DI-14_status | 0: OFF, 1: ON
0x000F | 10016 | R | bit | DI-15_status | 0: OFF, 1: ON
0x0000 | 30001 | R | word | DI-00_status | 0: OFF, 1: ON
0x0001 | 30002 | R | word | DI-01_status | 0: OFF, 1: ON
0x0002 | 30003 | R | word | DI-02_status | 0: OFF, 1: ON
0x0003 | 30004 | R | word | DI-03_status | 0: OFF, 1: ON
0x0004 | 30005 | R | word | DI-04_status | 0: OFF, 1: ON
0x0005 | 30006 | R | word | DI-05_status | 0: OFF, 1: ON
0x0006 | 30007 | R | word | DI-06_status | 0: OFF, 1: ON
0x0007 | 30008 | R | word | DI-07_status | 0: OFF, 1: ON
0x0008 | 30009 | R | word | DI-08_status | 0: OFF, 1: ON
0x0009 | 30010 | R | word | DI-09_status | 0: OFF, 1: ON
0x000A | 30011 | R | word | DI-10_status | 0: OFF, 1: ON
0x000B | 30012 | R | word | DI-11_status | 0: OFF, 1: ON
0x000C | 30013 | R | word | DI-12_status | 0: OFF, 1: ON
0x000D | 30014 | R | word | DI-13_status | 0: OFF, 1: ON
0x000E | 30015 | R | word | DI-14_status | 0: OFF, 1: ON
0x000F | 30016 | R | word | DI-15_status | 0: OFF, 1: ON
0x0020 | 30033 | R | word | DI-00_counterValueHigh | high word
0x0021 | 30034 | R | word | DI-00_counterValueLow | low word
0x0022 | 30035 | R | word | DI-01_counterValueHigh | high word
0x0023 | 30036 | R | word | DI-01_counterValueLow | low word
0x0024 | 30037 | R | word | DI-02_counterValueHigh | high word
0x0025 | 30038 | R | word | DI-02_counterValueLow | low word
0x0026 | 30039 | R | word | DI-03_counterValueHigh | high word
0x0027 | 30040 | R | word | DI-03_counterValueLow | low word
0x0028 | 30041 | R | word | DI-04_counterValueHigh | high word
0x0029 | 30042 | R | word | DI-04_counterValueLow | low word
0x002A | 30043 | R | word | DI-05_counterValueHigh | high word
0x002B | 30044 | R | word | DI-05_counterValueLow | low word
0x002C | 30045 | R | word | DI-06_counterValueHigh | high word
0x002D | 30046 | R | word | DI-06_counterValueLow | low word
0x002E | 30047 | R | word | DI-07_counterValueHigh | high word
0x002F | 30048 | R | word | DI-07_counterValueLow | low word
0x0030 | 30049 | R | word | DI-08_counterValueHigh | high word
0x0031 | 30050 | R | word | DI-08_counterValueLow | low word
0x0032 | 30051 | R | word | DI-09_counterValueHigh | high word
0x0033 | 30052 | R | word | DI-09_counterValueLow | low word
0x0034 | 30053 | R | word | DI-10_counterValueHigh | high word
0x0035 | 30054 | R | word | DI-10_counterValueLow | low word
0x0036 | 30055 | R | word | DI-11_counterValueHigh | high word
0x0037 | 30056 | R | word | DI-11_counterValueLow | low word
0x0038 | 30057 | R | word | DI-12_counterValueHigh | high word
0x0039 | 30058 | R | word | DI-12_counterValueLow | low word
0x003A | 30059 | R | word | DI-13_counterValueHigh | high word
0x003B | 30060 | R | word | DI-13_counterValueLow | low word
0x003C | 30061 | R | word | DI-14_counterValueHigh | high word
0x003D | 30062 | R | word | DI-14_counterValueLow | low word
0x003E | 30063 | R | word | DI-15_counterValueHigh | high word
0x003F | 30064 | R | word | DI-15_counterValueLow | low word
0x0000 | 40001 | R/W | word | DI-00_mode | 0: DI, 1: Counter
0x0001 | 40002 | R/W | word | DI-01_mode | 0: DI, 1: Counter
0x0002 | 40003 | R/W | word | DI-02_mode | 0: DI, 1: Counter
0x0003 | 40004 | R/W | word | DI-03_mode | 0: DI, 1: Counter
0x0004 | 40005 | R/W | word | DI-04_mode | 0: DI, 1: Counter
0x0005 | 40006 | R/W | word | DI-05_mode | 0: DI, 1: Counter
0x0006 | 40007 | R/W | word | DI-06_mode | 0: DI, 1: Counter
0x0007 | 40008 | R/W | word | DI-07_mode | 0: DI, 1: Counter
0x0008 | 40009 | R/W | word | DI-08_mode | 0: DI, 1: Counter
0x0009 | 40010 | R/W | word | DI-09_mode | 0: DI, 1: Counter
0x000A | 40011 | R/W | word | DI-10_mode | 0: DI, 1: Counter
0x000B | 40012 | R/W | word | DI-11_mode | 0: DI, 1: Counter
0x000C | 40013 | R/W | word | DI-12_mode | 0: DI, 1: Counter
0x000D | 40014 | R/W | word | DI-13_mode | 0: DI, 1: Counter
0x000E | 40015 | R/W | word | DI-14_mode | 0: DI, 1: Counter
0x000F | 40016 | R/W | word | DI-15_mode | 0: DI, 1: Counter
0x0020 | 40033 | R/W | word | DI-00_filter | unit: 100 us
0x0021 | 40034 | R/W | word | DI-01_filter | unit: 100 us
0x0022 | 40035 | R/W | word | DI-02_filter | unit: 100 us
0x0023 | 40036 | R/W | word | DI-03_filter | unit: 100 us
0x0024 | 40037 | R/W | word | DI-04_filter | unit: 100 us
0x0025 | 40038 | R/W | word | DI-05_filter | unit: 100 us
0x0026 | 40039 | R/W | word | DI-06_filter | unit: 100 us
0x0027 | 40040 | R/W | word | DI-07_filter | unit: 100 us
0x0028 | 40041 | R/W | word | DI-08_filter | unit: 100 us
0x0029 | 40042 | R/W | word | DI-09_filter | unit: 100 us
0x002A | 40043 | R/W | word | DI-10_filter | unit: 100 us
0x002B | 40044 | R/W | word | DI-11_filter | unit: 100 us
0x002C | 40045 | R/W | word | DI-12_filter | unit: 100 us
0x002D | 40046 | R/W | word | DI-13_filter | unit: 100 us
0x002E | 40047 | R/W | word | DI-14_filter | unit: 100 us
0x002F | 40048 | R/W | word | DI-15_filter | unit: 100 us
0x0040 | 40065 | R/W | word | DI-00_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0041 | 40066 | R/W | word | DI-01_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0042 | 40067 | R/W | word | DI-02_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0043 | 40068 | R/W | word | DI-03_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0044 | 40069 | R/W | word | DI-04_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0045 | 40070 | R/W | word | DI-05_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0046 | 40071 | R/W | word | DI-06_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0047 | 40072 | R/W | word | DI-07_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0048 | 40073 | R/W | word | DI-08_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0049 | 40074 | R/W | word | DI-09_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x004A | 40075 | R/W | word | DI-10_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x004B | 40076 | R/W | word | DI-11_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x004C | 40077 | R/W | word | DI-12_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x004D | 40078 | R/W | word | DI-13_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x004E | 40079 | R/W | word | DI-14_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x004F | 40080 | R/W | word | DI-15_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both


ioLogik R1212 Modbus Address and Register Map

Address (hex) | Register (decimal) | Access | Type | Parameter Name | Description
0x0000 | 00001 | R/W | bit | DI-00_counterStatus | 0: STOP, 1: START
0x0001 | 00002 | R/W | bit | DI-01_counterStatus | 0: STOP, 1: START
0x0002 | 00003 | R/W | bit | DI-02_counterStatus | 0: STOP, 1: START
0x0003 | 00004 | R/W | bit | DI-03_counterStatus | 0: STOP, 1: START
0x0004 | 00005 | R/W | bit | DI-04_counterStatus | 0: STOP, 1: START
0x0005 | 00006 | R/W | bit | DI-05_counterStatus | 0: STOP, 1: START
0x0006 | 00007 | R/W | bit | DI-06_counterStatus | 0: STOP, 1: START
0x0007 | 00008 | R/W | bit | DI-07_counterStatus | 0: STOP, 1: START
0x0008 | 00009 | R/W | bit | DI-08_counterStatus | 0: STOP, 1: START
0x0009 | 00010 | R/W | bit | DI-09_counterStatus | 0: STOP, 1: START
0x000A | 00011 | R/W | bit | DI-10_counterStatus | 0: STOP, 1: START
0x000B | 00012 | R/W | bit | DI-11_counterStatus | 0: STOP, 1: START
0x000C | 00013 | R/W | bit | DI-12_counterStatus | 0: STOP, 1: START
0x000D | 00014 | R/W | bit | DI-13_counterStatus | 0: STOP, 1: START
0x000E | 00015 | R/W | bit | DI-14_counterStatus | 0: STOP, 1: START
0x000F | 00016 | R/W | bit | DI-15_counterStatus | 0: STOP, 1: START
0x0020 | 00033 | R/W | bit | DI-00_counterReset | 1: reset to initial value
0x0021 | 00034 | R/W | bit | DI-01_counterReset | 1: reset to initial value
0x0022 | 00035 | R/W | bit | DI-02_counterReset | 1: reset to initial value
0x0023 | 00036 | R/W | bit | DI-03_counterReset | 1: reset to initial value
0x0024 | 00037 | R/W | bit | DI-04_counterReset | 1: reset to initial value
0x0025 | 00038 | R/W | bit | DI-05_counterReset | 1: reset to initial value
0x0026 | 00039 | R/W | bit | DI-06_counterReset | 1: reset to initial value
0x0027 | 00040 | R/W | bit | DI-07_counterReset | 1: reset to initial value
0x0028 | 00041 | R/W | bit | DI-08_counterReset | 1: reset to initial value
0x0029 | 00042 | R/W | bit | DI-09_counterReset | 1: reset to initial value
0x002A | 00043 | R/W | bit | DI-10_counterReset | 1: reset to initial value
0x002B | 00044 | R/W | bit | DI-11_counterReset | 1: reset to initial value
0x002C | 00045 | R/W | bit | DI-12_counterReset | 1: reset to initial value
0x002D | 00046 | R/W | bit | DI-13_counterReset | 1: reset to initial value
0x002E | 00047 | R/W | bit | DI-14_counterReset | 1: reset to initial value
0x002F | 00048 | R/W | bit | DI-15_counterReset | 1: reset to initial value
0x0040 | 00065 | R/W | bit | DI-00_counterOverflowFlag | 1: clear overflow flag
0x0041 | 00066 | R/W | bit | DI-01_counterOverflowFlag | 1: clear overflow flag
0x0042 | 00067 | R/W | bit | DI-02_counterOverflowFlag | 1: clear overflow flag
0x0043 | 00068 | R/W | bit | DI-03_counterOverflowFlag | 1: clear overflow flag
0x0044 | 00069 | R/W | bit | DI-04_counterOverflowFlag | 1: clear overflow flag
0x0045 | 00070 | R/W | bit | DI-05_counterOverflowFlag | 1: clear overflow flag
0x0046 | 00071 | R/W | bit | DI-06_counterOverflowFlag | 1: clear overflow flag
0x0047 | 00072 | R/W | bit | DI-07_counterOverflowFlag | 1: clear overflow flag
0x0048 | 00073 | R/W | bit | DI-08_counterOverflowFlag | 1: clear overflow flag
0x0049 | 00074 | R/W | bit | DI-09_counterOverflowFlag | 1: clear overflow flag
0x004A | 00075 | R/W | bit | DI-10_counterOverflowFlag | 1: clear overflow flag
0x004B | 00076 | R/W | bit | DI-11_counterOverflowFlag | 1: clear overflow flag
0x004C | 00077 | R/W | bit | DI-12_counterOverflowFlag | 1: clear overflow flag
0x004D | 00078 | R/W | bit | DI-13_counterOverflowFlag | 1: clear overflow flag
0x004E | 00079 | R/W | bit | DI-14_counterOverflowFlag | 1: clear overflow flag
0x004F | 00080 | R/W | bit | DI-15_counterOverflowFlag | 1: clear overflow flag
0x0060 | 00097 | R/W | bit | DI-00_counterPowerOnStatus | 0: STOP, 1: START
0x0061 | 00098 | R/W | bit | DI-01_counterPowerOnStatus | 0: STOP, 1: START
0x0062 | 00099 | R/W | bit | DI-02_counterPowerOnStatus | 0: STOP, 1: START
0x0063 | 00100 | R/W | bit | DI-03_counterPowerOnStatus | 0: STOP, 1: START
0x0064 | 00101 | R/W | bit | DI-04_counterPowerOnStatus | 0: STOP, 1: START
0x0065 | 00102 | R/W | bit | DI-05_counterPowerOnStatus | 0: STOP, 1: START
0x0066 | 00103 | R/W | bit | DI-06_counterPowerOnStatus | 0: STOP, 1: START
0x0067 | 00104 | R/W | bit | DI-07_counterPowerOnStatus | 0: STOP, 1: START
0x0068 | 00105 | R/W | bit | DI-08_counterPowerOnStatus | 0: STOP, 1: START
0x0069 | 00106 | R/W | bit | DI-09_counterPowerOnStatus | 0: STOP, 1: START
0x006A | 00107 | R/W | bit | DI-10_counterPowerOnStatus | 0: STOP, 1: START
0x006B | 00108 | R/W | bit | DI-11_counterPowerOnStatus | 0: STOP, 1: START
0x006C | 00109 | R/W | bit | DI-12_counterPowerOnStatus | 0: STOP, 1: START
0x006D | 00110 | R/W | bit | DI-13_counterPowerOnStatus | 0: STOP, 1: START
0x006E | 00111 | R/W | bit | DI-14_counterPowerOnStatus | 0: STOP, 1: START
0x006F | 00112 | R/W | bit | DI-15_counterPowerOnStatus | 0: STOP, 1: START
0x0080 | 00129 | R/W | bit | DI-00_counterSafeModeStatus | 0: STOP, 1: START
0x0081 | 00130 | R/W | bit | DI-01_counterSafeModeStatus | 0: STOP, 1: START
0x0082 | 00131 | R/W | bit | DI-02_counterSafeModeStatus | 0: STOP, 1: START
0x0083 | 00132 | R/W | bit | DI-03_counterSafeModeStatus | 0: STOP, 1: START
0x0084 | 00133 | R/W | bit | DI-04_counterSafeModeStatus | 0: STOP, 1: START
0x0085 | 00134 | R/W | bit | DI-05_counterSafeModeStatus | 0: STOP, 1: START
0x0086 | 00135 | R/W | bit | DI-06_counterSafeModeStatus | 0: STOP, 1: START
0x0087 | 00136 | R/W | bit | DI-07_counterSafeModeStatus | 0: STOP, 1: START
0x0088 | 00137 | R/W | bit | DI-08_counterSafeModeStatus | 0: STOP, 1: START
0x0089 | 00138 | R/W | bit | DI-09_counterSafeModeStatus | 0: STOP, 1: START
0x008A | 00139 | R/W | bit | DI-10_counterSafeModeStatus | 0: STOP, 1: START
0x008B | 00140 | R/W | bit | DI-11_counterSafeModeStatus | 0: STOP, 1: START
0x008C | 00141 | R/W | bit | DI-12_counterSafeModeStatus | 0: STOP, 1: START
0x008D | 00142 | R/W | bit | DI-13_counterSafeModeStatus | 0: STOP, 1: START
0x008E | 00143 | R/W | bit | DI-14_counterSafeModeStatus | 0: STOP, 1: START
0x008F | 00144 | R/W | bit | DI-15_counterSafeModeStatus | 0: STOP, 1: START
0x00A0 | 00161 | R/W | bit | DI-00_counterPowerOffStorage | 0: Disable, 1: Enable
0x00A1 | 00162 | R/W | bit | DI-01_counterPowerOffStorage | 0: Disable, 1: Enable
0x00A2 | 00163 | R/W | bit | DI-02_counterPowerOffStorage | 0: Disable, 1: Enable
0x00A3 | 00164 | R/W | bit | DI-03_counterPowerOffStorage | 0: Disable, 1: Enable
0x00A4 | 00165 | R/W | bit | DI-04_counterPowerOffStorage | 0: Disable, 1: Enable
0x00A5 | 00166 | R/W | bit | DI-05_counterPowerOffStorage | 0: Disable, 1: Enable
0x00A6 | 00167 | R/W | bit | DI-06_counterPowerOffStorage | 0: Disable, 1: Enable
0x00A7 | 00168 | R/W | bit | DI-07_counterPowerOffStorage | 0: Disable, 1: Enable
0x00A8 | 00169 | R/W | bit | DI-08_counterPowerOffStorage | 0: Disable, 1: Enable
0x00A9 | 00170 | R/W | bit | DI-09_counterPowerOffStorage | 0: Disable, 1: Enable
0x00AA | 00171 | R/W | bit | DI-10_counterPowerOffStorage | 0: Disable, 1: Enable
0x00AB | 00172 | R/W | bit | DI-11_counterPowerOffStorage | 0: Disable, 1: Enable
0x00AC | 00173 | R/W | bit | DI-12_counterPowerOffStorage | 0: Disable, 1: Enable
0x00AD | 00174 | R/W | bit | DI-13_counterPowerOffStorage | 0: Disable, 1: Enable
0x00AE | 00175 | R/W | bit | DI-14_counterPowerOffStorage | 0: Disable, 1: Enable
0x00AF | 00176 | R/W | bit | DI-15_counterPowerOffStorage | 0: Disable, 1: Enable
0x0140 | 00321 | R/W | bit | DO-00_status | 0: OFF, 1: ON
0x0141 | 00322 | R/W | bit | DO-01_status | 0: OFF, 1: ON
0x0142 | 00323 | R/W | bit | DO-02_status | 0: OFF, 1: ON
0x0143 | 00324 | R/W | bit | DO-03_status | 0: OFF, 1: ON
0x0144 | 00325 | R/W | bit | DO-04_status | 0: OFF, 1: ON
0x0145 | 00326 | R/W | bit | DO-05_status | 0: OFF, 1: ON
0x0146 | 00327 | R/W | bit | DO-06_status | 0: OFF, 1: ON
0x0147 | 00328 | R/W | bit | DO-07_status | 0: OFF, 1: ON
0x0160 | 00353 | R/W | bit | DO-00_powerOnStatus | 0: OFF, 1: ON
0x0161 | 00354 | R/W | bit | DO-01_powerOnStatus | 0: OFF, 1: ON
0x0162 | 00355 | R/W | bit | DO-02_powerOnStatus | 0: OFF, 1: ON
0x0163 | 00356 | R/W | bit | DO-03_powerOnStatus | 0: OFF, 1: ON
0x0164 | 00357 | R/W | bit | DO-04_powerOnStatus | 0: OFF, 1: ON
0x0165 | 00358 | R/W | bit | DO-05_powerOnStatus | 0: OFF, 1: ON
0x0166 | 00359 | R/W | bit | DO-06_powerOnStatus | 0: OFF, 1: ON
0x0167 | 00360 | R/W | bit | DO-07_powerOnStatus | 0: OFF, 1: ON
0x0180 | 00385 | R/W | bit | DO-00_pulseStatus | 0: STOP, 1: START
0x0181 | 00386 | R/W | bit | DO-01_pulseStatus | 0: STOP, 1: START
0x0182 | 00387 | R/W | bit | DO-02_pulseStatus | 0: STOP, 1: START
0x0183 | 00388 | R/W | bit | DO-03_pulseStatus | 0: STOP, 1: START
0x0184 | 00389 | R/W | bit | DO-04_pulseStatus | 0: STOP, 1: START
0x0185 | 00390 | R/W | bit | DO-05_pulseStatus | 0: STOP, 1: START
0x0186 | 00391 | R/W | bit | DO-06_pulseStatus | 0: STOP, 1: START
0x0187 | 00392 | R/W | bit | DO-07_pulseStatus | 0: STOP, 1: START
0x01A0 | 00417 | R/W | bit | DO-00_pulsePowerOnStatus | 0: STOP, 1: START
0x01A1 | 00418 | R/W | bit | DO-01_pulsePowerOnStatus | 0: STOP, 1: START
0x01A2 | 00419 | R/W | bit | DO-02_pulsePowerOnStatus | 0: STOP, 1: START
0x01A3 | 00420 | R/W | bit | DO-03_pulsePowerOnStatus | 0: STOP, 1: START
0x01A4 | 00421 | R/W | bit | DO-04_pulsePowerOnStatus | 0: STOP, 1: START
0x01A5 | 00422 | R/W | bit | DO-05_pulsePowerOnStatus | 0: STOP, 1: START
0x01A6 | 00423 | R/W | bit | DO-06_pulsePowerOnStatus | 0: STOP, 1: START
0x01A7 | 00424 | R/W | bit | DO-07_pulsePowerOnStatus | 0: STOP, 1: START
0x01C0 | 00449 | R/W | bit | DO-00_pulseSafeModeStatus | 0: STOP, 1: START
0x01C1 | 00450 | R/W | bit | DO-01_pulseSafeModeStatus | 0: STOP, 1: START
0x01C2 | 00451 | R/W | bit | DO-02_pulseSafeModeStatus | 0: STOP, 1: START
0x01C3 | 00452 | R/W | bit | DO-03_pulseSafeModeStatus | 0: STOP, 1: START
0x01C4 | 00453 | R/W | bit | DO-04_pulseSafeModeStatus | 0: STOP, 1: START
0x01C5 | 00454 | R/W | bit | DO-05_pulseSafeModeStatus | 0: STOP, 1: START
0x01C6 | 00455 | R/W | bit | DO-06_pulseSafeModeStatus | 0: STOP, 1: START
0x01C7 | 00456 | R/W | bit | DO-07_pulseSafeModeStatus | 0: STOP, 1: START
0x0000 | 10001 | R | bit | DI-00_status | 0: OFF, 1: ON
0x0001 | 10002 | R | bit | DI-01_status | 0: OFF, 1: ON
0x0002 | 10003 | R | bit | DI-02_status | 0: OFF, 1: ON
0x0003 | 10004 | R | bit | DI-03_status | 0: OFF, 1: ON
0x0004 | 10005 | R | bit | DI-04_status | 0: OFF, 1: ON
0x0005 | 10006 | R | bit | DI-05_status | 0: OFF, 1: ON
0x0006 | 10007 | R | bit | DI-06_status | 0: OFF, 1: ON
0x0007 | 10008 | R | bit | DI-07_status | 0: OFF, 1: ON
0x0008 | 10009 | R | bit | DI-08_status | 0: OFF, 1: ON
0x0009 | 10010 | R | bit | DI-09_status | 0: OFF, 1: ON
0x000A | 10011 | R | bit | DI-10_status | 0: OFF, 1: ON
0x000B | 10012 | R | bit | DI-11_status | 0: OFF, 1: ON
0x000C | 10013 | R | bit | DI-12_status | 0: OFF, 1: ON
0x000D | 10014 | R | bit | DI-13_status | 0: OFF, 1: ON
0x000E | 10015 | R | bit | DI-14_status | 0: OFF, 1: ON
0x000F | 10016 | R | bit | DI-15_status | 0: OFF, 1: ON
0x2830 | 10289 | R/W | bit | DIO-00_mode | 0: DI, 1: DO
0x2831 | 10290 | R/W | bit | DIO-01_mode | 0: DI, 1: DO
0x2832 | 10291 | R/W | bit | DIO-02_mode | 0: DI, 1: DO
0x2833 | 10292 | R/W | bit | DIO-03_mode | 0: DI, 1: DO
0x2834 | 10293 | R/W | bit | DIO-04_mode | 0: DI, 1: DO
0x2835 | 10294 | R/W | bit | DIO-05_mode | 0: DI, 1: DO
0x2836 | 10295 | R/W | bit | DIO-06_mode | 0: DI, 1: DO
0x2837 | 10296 | R/W | bit | DIO-07_mode | 0: DI, 1: DO
0x0000 | 30001 | R | word | DI-00_status | 0: OFF, 1: ON
0x0001 | 30002 | R | word | DI-01_status | 0: OFF, 1: ON
0x0002 | 30003 | R | word | DI-02_status | 0: OFF, 1: ON
0x0003 | 30004 | R | word | DI-03_status | 0: OFF, 1: ON
0x0004 | 30005 | R | word | DI-04_status | 0: OFF, 1: ON
0x0005 | 30006 | R | word | DI-05_status | 0: OFF, 1: ON
0x0006 | 30007 | R | word | DI-06_status | 0: OFF, 1: ON
0x0007 | 30008 | R | word | DI-07_status | 0: OFF, 1: ON
0x0008 | 30009 | R | word | DI-08_status | 0: OFF, 1: ON
0x0009 | 30010 | R | word | DI-09_status | 0: OFF, 1: ON
0x000A | 30011 | R | word | DI-10_status | 0: OFF, 1: ON
0x000B | 30012 | R | word | DI-11_status | 0: OFF, 1: ON
0x000C | 30013 | R | word | DI-12_status | 0: OFF, 1: ON
0x000D | 30014 | R | word | DI-13_status | 0: OFF, 1: ON
0x000E | 30015 | R | word | DI-14_status | 0: OFF, 1: ON
0x000F | 30016 | R | word | DI-15_status | 0: OFF, 1: ON
0x0020 | 30033 | R | word | DI-00_counterValueHigh | high word
0x0021 | 30034 | R | word | DI-00_counterValueLow | low word
0x0022 | 30035 | R | word | DI-01_counterValueHigh | high word
0x0023 | 30036 | R | word | DI-01_counterValueLow | low word
0x0024 | 30037 | R | word | DI-02_counterValueHigh | high word
0x0025 | 30038 | R | word | DI-02_counterValueLow | low word
0x0026 | 30039 | R | word | DI-03_counterValueHigh | high word
0x0027 | 30040 | R | word | DI-03_counterValueLow | low word
0x0028 | 30041 | R | word | DI-04_counterValueHigh | high word
0x0029 | 30042 | R | word | DI-04_counterValueLow | low word
0x002A | 30043 | R | word | DI-05_counterValueHigh | high word
0x002B | 30044 | R | word | DI-05_counterValueLow | low word
0x002C | 30045 | R | word | DI-06_counterValueHigh | high word
0x002D | 30046 | R | word | DI-06_counterValueLow | low word
0x002E | 30047 | R | word | DI-07_counterValueHigh | high word
0x002F | 30048 | R | word | DI-07_counterValueLow | low word
0x0030 | 30049 | R | word | DI-08_counterValueHigh | high word
0x0031 | 30050 | R | word | DI-08_counterValueLow | low word
0x0032 | 30051 | R | word | DI-09_counterValueHigh | high word
0x0033 | 30052 | R | word | DI-09_counterValueLow | low word
0x0034 | 30053 | R | word | DI-10_counterValueHigh | high word
0x0035 | 30054 | R | word | DI-10_counterValueLow | low word
0x0036 | 30055 | R | word | DI-11_counterValueHigh | high word
0x0037 | 30056 | R | word | DI-11_counterValueLow | low word
0x0038 | 30057 | R | word | DI-12_counterValueHigh | high word
0x0039 | 30058 | R | word | DI-12_counterValueLow | low word
0x003A | 30059 | R | word | DI-13_counterValueHigh | high word
0x003B | 30060 | R | word | DI-13_counterValueLow | low word
0x003C | 30061 | R | word | DI-14_counterValueHigh | high word
0x003D | 30062 | R | word | DI-14_counterValueLow | low word
0x003E | 30063 | R | word | DI-15_counterValueHigh | high word
0x003F | 30064 | R | word | DI-15_counterValueLow | low word
0x0120 | 30289 | R | word | DIO-00_mode | 0: DI, 1: DO
0x0121 | 30290 | R | word | DIO-01_mode | 0: DI, 1: DO
0x0122 | 30291 | R | word | DIO-02_mode | 0: DI, 1: DO
0x0123 | 30292 | R | word | DIO-03_mode | 0: DI, 1: DO
0x0124 | 30293 | R | word | DIO-04_mode | 0: DI, 1: DO
0x0125 | 30294 | R | word | DIO-05_mode | 0: DI, 1: DO
0x0126 | 30295 | R | word | DIO-06_mode | 0: DI, 1: DO
0x0127 | 30296 | R | word | DIO-07_mode | 0: DI, 1: DO
0x0000 | 40001 | R/W | word | DI-00_mode | 0: DI, 1: Counter
0x0001 | 40002 | R/W | word | DI-01_mode | 0: DI, 1: Counter
0x0002 | 40003 | R/W | word | DI-02_mode | 0: DI, 1: Counter
0x0003 | 40004 | R/W | word | DI-03_mode | 0: DI, 1: Counter
0x0004 | 40005 | R/W | word | DI-04_mode | 0: DI, 1: Counter
0x0005 | 40006 | R/W | word | DI-05_mode | 0: DI, 1: Counter
0x0006 | 40007 | R/W | word | DI-06_mode | 0: DI, 1: Counter
0x0007 | 40008 | R/W | word | DI-07_mode | 0: DI, 1: Counter
0x0008 | 40009 | R/W | word | DI-08_mode | 0: DI, 1: Counter
0x0009 | 40010 | R/W | word | DI-09_mode | 0: DI, 1: Counter
0x000A | 40011 | R/W | word | DI-10_mode | 0: DI, 1: Counter
0x000B | 40012 | R/W | word | DI-11_mode | 0: DI, 1: Counter
0x000C | 40013 | R/W | word | DI-12_mode | 0: DI, 1: Counter
0x000D | 40014 | R/W | word | DI-13_mode | 0: DI, 1: Counter
0x000E | 40015 | R/W | word | DI-14_mode | 0: DI, 1: Counter
0x000F | 40016 | R/W | word | DI-15_mode | 0: DI, 1: Counter
0x0020 | 40033 | R/W | word | DI-00_filter | unit: 100 us
0x0021 | 40034 | R/W | word | DI-01_filter | unit: 100 us
0x0022 | 40035 | R/W | word | DI-02_filter | unit: 100 us
0x0023 | 40036 | R/W | word | DI-03_filter | unit: 100 us
0x0024 | 40037 | R/W | word | DI-04_filter | unit: 100 us
0x0025 | 40038 | R/W | word | DI-05_filter | unit: 100 us
0x0026 | 40039 | R/W | word | DI-06_filter | unit: 100 us
0x0027 | 40040 | R/W | word | DI-07_filter | unit: 100 us
0x0028 | 40041 | R/W | word | DI-08_filter | unit: 100 us
0x0029 | 40042 | R/W | word | DI-09_filter | unit: 100 us
0x002A | 40043 | R/W | word | DI-10_filter | unit: 100 us
0x002B | 40044 | R/W | word | DI-11_filter | unit: 100 us
0x002C | 40045 | R/W | word | DI-12_filter | unit: 100 us
0x002D | 40046 | R/W | word | DI-13_filter | unit: 100 us
0x002E | 40047 | R/W | word | DI-14_filter | unit: 100 us
0x002F | 40048 | R/W | word | DI-15_filter | unit: 100 us
0x0040 | 40065 | R/W | word | DI-00_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0041 | 40066 | R/W | word | DI-01_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0042 | 40067 | R/W | word | DI-02_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0043 | 40068 | R/W | word | DI-03_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0044 | 40069 | R/W | word | DI-04_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0045 | 40070 | R/W | word | DI-05_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0046 | 40071 | R/W | word | DI-06_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0047 | 40072 | R/W | word | DI-07_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0048 | 40073 | R/W | word | DI-08_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0049 | 40074 | R/W | word | DI-09_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x004A | 40075 | R/W | word | DI-10_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x004B | 40076 | R/W | word | DI-11_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x004C | 40077 | R/W | word | DI-12_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x004D | 40078 | R/W | word | DI-13_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x004E | 40079 | R/W | word | DI-14_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x004F | 40080 | R/W | word | DI-15_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0140 | 40321 | R/W | word | DO-00_status | 0: OFF, 1: ON
0x0141 | 40322 | R/W | word | DO-01_status | 0: OFF, 1: ON
0x0142 | 40323 | R/W | word | DO-02_status | 0: OFF, 1: ON
0x0143 | 40324 | R/W | word | DO-03_status | 0: OFF, 1: ON
0x0144 | 40325 | R/W | word | DO-04_status | 0: OFF, 1: ON
0x0145 | 40326 | R/W | word | DO-05_status | 0: OFF, 1: ON
0x0146 | 40327 | R/W | word | DO-06_status | 0: OFF, 1: ON
0x0147 | 40328 | R/W | word | DO-07_status | 0: OFF, 1: ON
0x01A0 | 40417 | R/W | word | DO-00_pulseOnWidth | unit: 1 ms
0x01A0 | 40417 | R/W | word | DO-08_pulseOnWidth | unit: 1 ms
0x01A1 | 40418 | R/W | word | DO-01_pulseOnWidth | unit: 1 ms
0x01A1 | 40418 | R/W | word | DO-09_pulseOnWidth | unit: 1 ms
0x01A2 | 40419 | R/W | word | DO-02_pulseOnWidth | unit: 1 ms
0x01A2 | 40419 | R/W | word | DO-10_pulseOnWidth | unit: 1 ms
0x01A3 | 40420 | R/W | word | DO-03_pulseOnWidth | unit: 1 ms
0x01A3 | 40420 | R/W | word | DO-11_pulseOnWidth | unit: 1 ms
0x01A4 | 40421 | R/W | word | DO-04_pulseOnWidth | unit: 1 ms
0x01A4 | 40421 | R/W | word | DO-12_pulseOnWidth | unit: 1 ms
0x01A5 | 40422 | R/W | word | DO-05_pulseOnWidth | unit: 1 ms
0x01A5 | 40422 | R/W | word | DO-13_pulseOnWidth | unit: 1 ms
0x01A6 | 40423 | R/W | word | DO-06_pulseOnWidth | unit: 1 ms
0x01A6 | 40423 | R/W | word | DO-14_pulseOnWidth | unit: 1 ms
0x01A7 | 40424 | R/W | word | DO-07_pulseOnWidth | unit: 1 ms
0x01A7 | 40424 | R/W | word | DO-15_pulseOnWidth | unit: 1 ms
0x01C0 | 40449 | R/W | word | DO-00_pulseOffWidth | unit: 1 ms
0x01C0 | 40449 | R/W | word | DO-08_pulseOffWidth | unit: 1 ms
0x01C1 | 40450 | R/W | word | DO-01_pulseOffWidth | unit: 1 ms
0x01C1 | 40450 | R/W | word | DO-09_pulseOffWidth | unit: 1 ms
0x01C2 | 40451 | R/W | word | DO-02_pulseOffWidth | unit: 1 ms
0x01C2 | 40451 | R/W | word | DO-10_pulseOffWidth | unit: 1 ms
0x01C3 | 40452 | R/W | word | DO-03_pulseOffWidth | unit: 1 ms
0x01C3 | 40452 | R/W | word | DO-11_pulseOffWidth | unit: 1 ms
0x01C4 | 40453 | R/W | word | DO-04_pulseOffWidth | unit: 1 ms
0x01C4 | 40453 | R/W | word | DO-12_pulseOffWidth | unit: 1 ms
0x01C5 | 40454 | R/W | word | DO-05_pulseOffWidth | unit: 1 ms
0x01C5 | 40454 | R/W | word | DO-13_pulseOffWidth | unit: 1 ms
0x01C6 | 40455 | R/W | word | DO-06_pulseOffWidth | unit: 1 ms
0x01C6 | 40455 | R/W | word | DO-14_pulseOffWidth | unit: 1 ms
0x01C7 | 40456 | R/W | word | DO-07_pulseOffWidth | unit: 1 ms
0x01C7 | 40456 | R/W | word | DO-15_pulseOffWidth | unit: 1 ms
0x9E20 | 40481 | R/W | bit | DO-00_safeModeStatus | 0: OFF, 1: ON, 2: Hold Last
0x9E21 | 40482 | R/W | bit | DO-01_safeModeStatus | 0: OFF, 1: ON, 2: Hold Last
0x9E22 | 40483 | R/W | bit | DO-02_safeModeStatus | 0: OFF, 1: ON, 2: Hold Last
0x9E23 | 40484 | R/W | bit | DO-03_safeModeStatus | 0: OFF, 1: ON, 2: Hold Last
0x9E24 | 40485 | R/W | bit | DO-04_safeModeStatus | 0: OFF, 1: ON, 2: Hold Last
0x9E25 | 40486 | R/W | bit | DO-05_safeModeStatus | 0: OFF, 1: ON, 2: Hold Last
0x9E26 | 40487 | R/W | bit | DO-06_safeModeStatus | 0: OFF, 1: ON, 2: Hold Last
0x9E27 | 40488 | R/W | bit | DO-07_safeModeStatus | 0: OFF, 1: ON, 2: Hold Last
0x9E40 | 40513 | R/W | bit | DO-00_mode | 0: DO, 1: Pulse
0x9E41 | 40514 | R/W | bit | DO-01_mode | 0: DO, 1: Pulse
0x9E42 | 40515 | R/W | bit | DO-02_mode | 0: DO, 1: Pulse
0x9E43 | 40516 | R/W | bit | DO-03_mode | 0: DO, 1: Pulse
0x9E44 | 40517 | R/W | bit | DO-04_mode | 0: DO, 1: Pulse
0x9E45 | 40518 | R/W | bit | DO-05_mode | 0: DO, 1: Pulse
0x9E46 | 40519 | R/W | bit | DO-06_mode | 0: DO, 1: Pulse
0x9E47 | 40520 | R/W | bit | DO-07_mode | 0: DO, 1: Pulse


ioLogik R1214 Modbus Address and Register Map

Address (hex) | Register (decimal) | Access | Type | Parameter Name | Description
0x0000 | 00001 | R/W | bit | DI-00_counterStatus | 0: STOP, 1: START
0x0001 | 00002 | R/W | bit | DI-01_counterStatus | 0: STOP, 1: START
0x0002 | 00003 | R/W | bit | DI-02_counterStatus | 0: STOP, 1: START
0x0003 | 00004 | R/W | bit | DI-03_counterStatus | 0: STOP, 1: START
0x0004 | 00005 | R/W | bit | DI-04_counterStatus | 0: STOP, 1: START
0x0005 | 00006 | R/W | bit | DI-05_counterStatus | 0: STOP, 1: START
0x0020 | 00033 | R/W | bit | DI-00_counterReset | 1: reset to initial value
0x0021 | 00034 | R/W | bit | DI-01_counterReset | 1: reset to initial value
0x0022 | 00035 | R/W | bit | DI-02_counterReset | 1: reset to initial value
0x0023 | 00036 | R/W | bit | DI-03_counterReset | 1: reset to initial value
0x0024 | 00037 | R/W | bit | DI-04_counterReset | 1: reset to initial value
0x0025 | 00038 | R/W | bit | DI-05_counterReset | 1: reset to initial value
0x0040 | 00065 | R/W | bit | DI-00_counterOverflowFlag | 1: clear overflow flag
0x0041 | 00066 | R/W | bit | DI-01_counterOverflowFlag | 1: clear overflow flag
0x0042 | 00067 | R/W | bit | DI-02_counterOverflowFlag | 1: clear overflow flag
0x0043 | 00068 | R/W | bit | DI-03_counterOverflowFlag | 1: clear overflow flag
0x0044 | 00069 | R/W | bit | DI-04_counterOverflowFlag | 1: clear overflow flag
0x0045 | 00070 | R/W | bit | DI-05_counterOverflowFlag | 1: clear overflow flag
0x0060 | 00097 | R/W | bit | DI-00_counterPowerOnStatus | 0: STOP, 1: START
0x0061 | 00098 | R/W | bit | DI-01_counterPowerOnStatus | 0: STOP, 1: START
0x0062 | 00099 | R/W | bit | DI-02_counterPowerOnStatus | 0: STOP, 1: START
0x0063 | 00100 | R/W | bit | DI-03_counterPowerOnStatus | 0: STOP, 1: START
0x0064 | 00101 | R/W | bit | DI-04_counterPowerOnStatus | 0: STOP, 1: START
0x0065 | 00102 | R/W | bit | DI-05_counterPowerOnStatus | 0: STOP, 1: START
0x0080 | 00129 | R/W | bit | DI-00_counterSafeModeStatus | 0: STOP, 1: START
0x0081 | 00130 | R/W | bit | DI-01_counterSafeModeStatus | 0: STOP, 1: START
0x0082 | 00131 | R/W | bit | DI-02_counterSafeModeStatus | 0: STOP, 1: START
0x0083 | 00132 | R/W | bit | DI-03_counterSafeModeStatus | 0: STOP, 1: START
0x0084 | 00133 | R/W | bit | DI-04_counterSafeModeStatus | 0: STOP, 1: START
0x0085 | 00134 | R/W | bit | DI-05_counterSafeModeStatus | 0: STOP, 1: START
0x00A0 | 00161 | R/W | bit | DI-00_counterPowerOffStorage | 0: Disable, 1: Enable
0x00A1 | 00162 | R/W | bit | DI-01_counterPowerOffStorage | 0: Disable, 1: Enable
0x00A2 | 00163 | R/W | bit | DI-02_counterPowerOffStorage | 0: Disable, 1: Enable
0x00A3 | 00164 | R/W | bit | DI-03_counterPowerOffStorage | 0: Disable, 1: Enable
0x00A4 | 00165 | R/W | bit | DI-04_counterPowerOffStorage | 0: Disable, 1: Enable
0x00A5 | 00166 | R/W | bit | DI-05_counterPowerOffStorage | 0: Disable, 1: Enable
0x0140 | 00321 | R/W | bit | RLY-00_status | 0: OFF, 1: ON
0x0141 | 00322 | R/W | bit | RLY-01_status | 0: OFF, 1: ON
0x0142 | 00323 | R/W | bit | RLY-02_status | 0: OFF, 1: ON
0x0143 | 00324 | R/W | bit | RLY-03_status | 0: OFF, 1: ON
0x0144 | 00325 | R/W | bit | RLY-04_status | 0: OFF, 1: ON
0x0145 | 00326 | R/W | bit | RLY-05_status | 0: OFF, 1: ON
0x0160 | 00353 | R/W | bit | RLY-00_powerOnStatus | 0: OFF, 1: ON
0x0161 | 00354 | R/W | bit | RLY-01_powerOnStatus | 0: OFF, 1: ON
0x0162 | 00355 | R/W | bit | RLY-02_powerOnStatus | 0: OFF, 1: ON
0x0163 | 00356 | R/W | bit | RLY-03_powerOnStatus | 0: OFF, 1: ON
0x0164 | 00357 | R/W | bit | RLY-04_powerOnStatus | 0: OFF, 1: ON
0x0165 | 00358 | R/W | bit | RLY-05_powerOnStatus | 0: OFF, 1: ON
0x0180 | 00385 | R/W | bit | RLY-00_pulseStatus | 0: STOP, 1: START
0x0181 | 00386 | R/W | bit | RLY-01_pulseStatus | 0: STOP, 1: START
0x0182 | 00387 | R/W | bit | RLY-02_pulseStatus | 0: STOP, 1: START
0x0183 | 00388 | R/W | bit | RLY-03_pulseStatus | 0: STOP, 1: START
0x0184 | 00389 | R/W | bit | RLY-04_pulseStatus | 0: STOP, 1: START
0x0185 | 00390 | R/W | bit | RLY-05_pulseStatus | 0: STOP, 1: START
0x01A0 | 00417 | R/W | bit | RLY-00_pulsePowerOnStatus | 0: STOP, 1: START
0x01A1 | 00418 | R/W | bit | RLY-01_pulsePowerOnStatus | 0: STOP, 1: START
0x01A2 | 00419 | R/W | bit | RLY-02_pulsePowerOnStatus | 0: STOP, 1: START
0x01A3 | 00420 | R/W | bit | RLY-03_pulsePowerOnStatus | 0: STOP, 1: START
0x01A4 | 00421 | R/W | bit | RLY-04_pulsePowerOnStatus | 0: STOP, 1: START
0x01A5 | 00422 | R/W | bit | RLY-05_pulsePowerOnStatus | 0: STOP, 1: START
0x01C0 | 00449 | R/W | bit | RLY-00_pulseSafeModeStatus | 0: STOP, 1: START
0x01C1 | 00450 | R/W | bit | RLY-01_pulseSafeModeStatus | 0: STOP, 1: START
0x01C2 | 00451 | R/W | bit | RLY-02_pulseSafeModeStatus | 0: STOP, 1: START
0x01C3 | 00452 | R/W | bit | RLY-03_pulseSafeModeStatus | 0: STOP, 1: START
0x01C4 | 00453 | R/W | bit | RLY-04_pulseSafeModeStatus | 0: STOP, 1: START
0x01C5 | 00454 | R/W | bit | RLY-05_pulseSafeModeStatus | 0: STOP, 1: START
0x01DF | 00480 | R/W | bit | RLY-00_pulseReset | 1: reset pulse count
0x01E0 | 00481 | R/W | bit | RLY-01_pulseReset | 1: reset pulse count
0x01E1 | 00482 | R/W | bit | RLY-02_pulseReset | 1: reset pulse count
0x01E2 | 00483 | R/W | bit | RLY-03_pulseReset | 1: reset pulse count
0x01E3 | 00484 | R/W | bit | RLY-04_pulseReset | 1: reset pulse count
0x01E4 | 00485 | R/W | bit | RLY-05_pulseReset | 1: reset pulse count
0x0000 | 10001 | R | bit | DI-00_status | 0: OFF, 1: ON
0x0001 | 10002 | R | bit | DI-01_status | 0: OFF, 1: ON
0x0002 | 10003 | R | bit | DI-02_status | 0: OFF, 1: ON
0x0003 | 10004 | R | bit | DI-03_status | 0: OFF, 1: ON
0x0004 | 10005 | R | bit | DI-04_status | 0: OFF, 1: ON
0x0005 | 10006 | R | bit | DI-05_status | 0: OFF, 1: ON
0x0000 | 30001 | R | word | DI-00_status | 0: OFF, 1: ON
0x0001 | 30002 | R | word | DI-01_status | 0: OFF, 1: ON
0x0002 | 30003 | R | word | DI-02_status | 0: OFF, 1: ON
0x0003 | 30004 | R | word | DI-03_status | 0: OFF, 1: ON
0x0004 | 30005 | R | word | DI-04_status | 0: OFF, 1: ON
0x0005 | 30006 | R | word | DI-05_status | 0: OFF, 1: ON
0x0020 | 30033 | R | word | DI-00_counterValueHigh | high word
0x0021 | 30034 | R | word | DI-00_counterValueLow | low word
0x0022 | 30035 | R | word | DI-01_counterValueHigh | high word
0x0023 | 30036 | R | word | DI-01_counterValueLow | low word
0x0024 | 30037 | R | word | DI-02_counterValueHigh | high word
0x0025 | 30038 | R | word | DI-02_counterValueLow | low word
0x0026 | 30039 | R | word | DI-03_counterValueHigh | high word
0x0027 | 30040 | R | word | DI-03_counterValueLow | low word
0x0028 | 30041 | R | word | DI-04_counterValueHigh | high word
0x0029 | 30042 | R | word | DI-04_counterValueLow | low word
0x002A | 30043 | R | word | DI-05_counterValueHigh | high word
0x002B | 30044 | R | word | DI-05_counterValueLow | low word
0x0140 | 30321 | R | word | RLY-00_totalCountHigh | high word
0x0141 | 30322 | R | word | RLY-00_totalCountLow | low word
0x0142 | 30323 | R | word | RLY-01_totalCountHigh | high word
0x0143 | 30324 | R | word | RLY-01_totalCountLow | low word
0x0144 | 30325 | R | word | RLY-02_totalCountHigh | high word
0x0145 | 30326 | R | word | RLY-02_totalCountLow | low word
0x0146 | 30327 | R | word | RLY-03_totalCountHigh | high word
0x0147 | 30328 | R | word | RLY-03_totalCountLow | low word
0x0148 | 30329 | R | word | RLY-04_totalCountHigh | high word
0x0149 | 30330 | R | word | RLY-04_totalCountLow | low word
0x014A | 30331 | R | word | RLY-05_totalCountHigh | high word
0x014B | 30332 | R | word | RLY-05_totalCountLow | low word
0x0180 | 30385 | R | word | RLY-00_currentCountHigh | high word
0x0181 | 30386 | R | word | RLY-00_currentCountLow | low word
0x0182 | 30387 | R | word | RLY-01_currentCountHigh | high word
0x0183 | 30388 | R | word | RLY-01_currentCountLow | low word
0x0184 | 30389 | R | word | RLY-02_currentCountHigh | high word
0x0185 | 30390 | R | word | RLY-02_currentCountLow | low word
0x0186 | 30391 | R | word | RLY-03_currentCountHigh | high word
0x0187 | 30392 | R | word | RLY-03_currentCountLow | low word
0x0188 | 30393 | R | word | RLY-04_currentCountHigh | high word
0x0189 | 30394 | R | word | RLY-04_currentCountLow | low word
0x018A | 30395 | R | word | RLY-05_currentCountHigh | high word
0x018B | 30396 | R | word | RLY-05_currentCountLow | low word
0x0000 | 40001 | R/W | word | DI-00_mode | 0: DI, 1: Counter
0x0001 | 40002 | R/W | word | DI-01_mode | 0: DI, 1: Counter
0x0002 | 40003 | R/W | word | DI-02_mode | 0: DI, 1: Counter
0x0003 | 40004 | R/W | word | DI-03_mode | 0: DI, 1: Counter
0x0004 | 40005 | R/W | word | DI-04_mode | 0: DI, 1: Counter
0x0005 | 40006 | R/W | word | DI-05_mode | 0: DI, 1: Counter
0x0020 | 40033 | R/W | word | DI-00_filter | unit: 100 us
0x0021 | 40034 | R/W | word | DI-01_filter | unit: 100 us
0x0022 | 40035 | R/W | word | DI-02_filter | unit: 100 us
0x0023 | 40036 | R/W | word | DI-03_filter | unit: 100 us
0x0024 | 40037 | R/W | word | DI-04_filter | unit: 100 us
0x0025 | 40038 | R/W | word | DI-05_filter | unit: 100 us
0x0040 | 40065 | R/W | word | DI-00_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0041 | 40066 | R/W | word | DI-01_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0042 | 40067 | R/W | word | DI-02_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0043 | 40068 | R/W | word | DI-03_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0044 | 40069 | R/W | word | DI-04_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0045 | 40070 | R/W | word | DI-05_counterEvent | 0: Rising Edge, 1: Falling Edge, 2: Both
0x0140 | 40321 | R/W | word | RLY-00_status | 0: OFF, 1: ON
0x0141 | 40322 | R/W | word | RLY-01_status | 0: OFF, 1: ON
0x0142 | 40323 | R/W | word | RLY-02_status | 0: OFF, 1: ON
0x0143 | 40324 | R/W | word | RLY-03_status | 0: OFF, 1: ON
0x0144 | 40325 | R/W | word | RLY-04_status | 0: OFF, 1: ON
0x0145 | 40326 | R/W | word | RLY-05_status | 0: OFF, 1: ON
0x0160 | 40353 | R/W | word | RLY-00_pulseCountHigh | high word
0x0161 | 40354 | R/W | word | RLY-00_pulseCountLow | low word
0x0162 | 40355 | R/W | word | RLY-01_pulseCountHigh | high word
0x0163 | 40356 | R/W | word | RLY-01_pulseCountLow | low word
0x0164 | 40357 | R/W | word | RLY-02_pulseCountHigh | high word
0x0165 | 40358 | R/W | word | RLY-02_pulseCountLow | low word
0x0166 | 40359 | R/W | word | RLY-03_pulseCountHigh | high word
0x0167 | 40360 | R/W | word | RLY-03_pulseCountLow | low word
0x0168 | 40361 | R/W | word | RLY-04_pulseCountHigh | high word
0x0169 | 40362 | R/W | word | RLY-04_pulseCountLow | low word
0x016A | 40363 | R/W | word | RLY-05_pulseCountHigh | high word
0x016B | 40364 | R/W | word | RLY-05_pulseCountLow | low word
0x01E0 | 40481 | R/W | word | RLY-00_safeModeStatus | 0: OFF, 1: ON, 2: Hold Last
0x01E1 | 40482 | R/W | word | RLY-01_safeModeStatus | 0: OFF, 1: ON, 2: Hold Last
0x01E2 | 40483 | R/W | word | RLY-02_safeModeStatus | 0: OFF, 1: ON, 2: Hold Last
0x01E3 | 40484 | R/W | word | RLY-03_safeModeStatus | 0: OFF, 1: ON, 2: Hold Last
0x01E4 | 40485 | R/W | word | RLY-04_safeModeStatus | 0: OFF, 1: ON, 2: Hold Last
0x01E5 | 40486 | R/W | word | RLY-05_safeModeStatus | 0: OFF, 1: ON, 2: Hold Last
0x01E6 | 40487 | R/W | word | RLY-06_safeModeStatus | 0: OFF, 1: ON, 2: Hold Last
0x01E7 | 40488 | R/W | word | RLY-07_safeModeStatus | 0: OFF, 1: ON, 2: Hold Last
0x0220 | 40545 | R/W | word | RLY-00_PowerOnDelay | unit: sec(s)
0x0221 | 40546 | R/W | word | RLY-01_PowerOnDelay | unit: sec(s)
0x0222 | 40547 | R/W | word | RLY-02_PowerOnDelay | unit: sec(s)
0x0223 | 40548 | R/W | word | RLY-03_PowerOnDelay | unit: sec(s)
0x0224 | 40549 | R/W | word | RLY-04_PowerOnDelay | unit: sec(s)
0x0225 | 40550 | R/W | word | RLY-05_PowerOnDelay | unit: sec(s)


ioLogik R1240 Modbus Address and Register Map

Address (hex) | Register (decimal) | Access | Type | Parameter Name | Description
0x02C0 | 00705 | R/W | bit | AI-00_resetMinValue | 1: reset min. value
0x02C1 | 00706 | R/W | bit | AI-01_resetMinValue | 1: reset min. value
0x02C2 | 00707 | R/W | bit | AI-02_resetMinValue | 1: reset min. value
0x02C3 | 00708 | R/W | bit | AI-03_resetMinValue | 1: reset min. value
0x02C4 | 00709 | R/W | bit | AI-04_resetMinValue | 1: reset min. value
0x02C5 | 00710 | R/W | bit | AI-05_resetMinValue | 1: reset min. value
0x02C6 | 00711 | R/W | bit | AI-06_resetMinValue | 1: reset min. value
0x02C7 | 00712 | R/W | bit | AI-07_resetMinValue | 1: reset min. value
0x02E0 | 00737 | R/W | bit | AI-00_resetMaxValue | 1: reset max. value
0x02E1 | 00738 | R/W | bit | AI-01_resetMaxValue | 1: reset max. value
0x02E2 | 00739 | R/W | bit | AI-02_resetMaxValue | 1: reset max. value
0x02E3 | 00740 | R/W | bit | AI-03_resetMaxValue | 1: reset max. value
0x02E4 | 00741 | R/W | bit | AI-04_resetMaxValue | 1: reset max. value
0x02E5 | 00742 | R/W | bit | AI-05_resetMaxValue | 1: reset max. value
0x02E6 | 00743 | R/W | bit | AI-06_resetMaxValue | 1: reset max. value
0x02E7 | 00744 | R/W | bit | AI-07_resetMaxValue | 1: reset max. value
0x02C0 | 30705 | R | word | AI-00_rawValue |
0x02C1 | 30706 | R | word | AI-01_rawValue |
0x02C2 | 30707 | R | word | AI-02_rawValue |
0x02C3 | 30708 | R | word | AI-03_rawValue |
0x02C4 | 30709 | R | word | AI-04_rawValue |
0x02C5 | 30710 | R | word | AI-05_rawValue |
0x02C6 | 30711 | R | word | AI-06_rawValue |
0x02C7 | 30712 | R | word | AI-07_rawValue |
0x02E0 | 30737 | R | word | AI-00_rawValueMin |
0x02E1 | 30738 | R | word | AI-01_rawValueMin |
0x02E2 | 30739 | R | word | AI-02_rawValueMin |
0x02E3 | 30740 | R | word | AI-03_rawValueMin |
0x02E4 | 30741 | R | word | AI-04_rawValueMin |
0x02E5 | 30742 | R | word | AI-05_rawValueMin |
0x02E6 | 30743 | R | word | AI-06_rawValueMin |
0x02E7 | 30744 | R | word | AI-07_rawValueMin |
0x0300 | 30769 | R | word | AI-00_rawValueMax |
0x0301 | 30770 | R | word | AI-01_rawValueMax |
0x0302 | 30771 | R | word | AI-02_rawValueMax |
0x0303 | 30772 | R | word | AI-03_rawValueMax |
0x0304 | 30773 | R | word | AI-04_rawValueMax |
0x0305 | 30774 | R | word | AI-05_rawValueMax |
0x0306 | 30775 | R | word | AI-06_rawValueMax |
0x0307 | 30776 | R | word | AI-07_rawValueMax |
0x0320 | 30801 | R | word | AI-00_engineeringValueHigh | high word
0x0321 | 30802 | R | word | AI-00_engineeringValueLow | low word
0x0322 | 30803 | R | word | AI-01_engineeringValueHigh | high word
0x0323 | 30804 | R | word | AI-01_engineeringValueLow | low word
0x0324 | 30805 | R | word | AI-02_engineeringValueHigh | high word
0x0325 | 30806 | R | word | AI-02_engineeringValueLow | low word
0x0326 | 30807 | R | word | AI-03_engineeringValueHigh | high word
0x0327 | 30808 | R | word | AI-03_engineeringValueLow | low word
0x0328 | 30809 | R | word | AI-04_engineeringValueHigh | high word
0x0329 | 30810 | R | word | AI-04_engineeringValueLow | low word
0x032A | 30811 | R | word | AI-05_engineeringValueHigh | high word
0x032B | 30812 | R | word | AI-05_engineeringValueLow | low word
0x032C | 30813 | R | word | AI-06_engineeringValueHigh | high word
0x032D | 30814 | R | word | AI-06_engineeringValueLow | low word
0x032E | 30815 | R | word | AI-07_engineeringValueHigh | high word
0x032F | 30816 | R | word | AI-07_engineeringValueLow | low word
0x0360 | 30865 | R | word | AI-00_engineeringValueMinHigh | high word
0x0361 | 30866 | R | word | AI-00_engineeringValueMinLow | low word
0x0362 | 30867 | R | word | AI-01_engineeringValueMinHigh | high word
0x0363 | 30868 | R | word | AI-01_engineeringValueMinLow | low word
0x0364 | 30869 | R | word | AI-02_engineeringValueMinHigh | high word
0x0365 | 30870 | R | word | AI-02_engineeringValueMinLow | low word
0x0366 | 30871 | R | word | AI-03_engineeringValueMinHigh | high word
0x0367 | 30872 | R | word | AI-03_engineeringValueMinLow | low word
0x0368 | 30873 | R | word | AI-04_engineeringValueMinHigh | high word
0x0369 | 30874 | R | word | AI-04_engineeringValueMinLow | low word
0x036A | 30875 | R | word | AI-05_engineeringValueMinHigh | high word
0x036B | 30876 | R | word | AI-05_engineeringValueMinLow | low word
0x036C | 30877 | R | word | AI-06_engineeringValueMinHigh | high word
0x036D | 30878 | R | word | AI-06_engineeringValueMinLow | low word
0x036E | 30879 | R | word | AI-07_engineeringValueMinHigh | high word
0x036F | 30880 | R | word | AI-07_engineeringValueMinLow | low word
0x03A0 | 30929 | R | word | AI-00_engineeringValueMaxHigh | high word
0x03A1 | 30930 | R | word | AI-00_engineeringValueMaxLow | low word
0x03A2 | 30931 | R | word | AI-01_engineeringValueMaxHigh | high word
0x03A3 | 30932 | R | word | AI-01_engineeringValueMaxLow | low word
0x03A4 | 30933 | R | word | AI-02_engineeringValueMaxHigh | high word
0x03A5 | 30934 | R | word | AI-02_engineeringValueMaxLow | low word
0x03A6 | 30935 | R | word | AI-03_engineeringValueMaxHigh | high word
0x03A7 | 30936 | R | word | AI-03_engineeringValueMaxLow | low word
0x03A8 | 30937 | R | word | AI-04_engineeringValueMaxHigh | high word
0x03A9 | 30938 | R | word | AI-04_engineeringValueMaxLow | low word
0x03AA | 30939 | R | word | AI-05_engineeringValueMaxHigh | high word
0x03AB | 30940 | R | word | AI-05_engineeringValueMaxLow | low word
0x03AC | 30941 | R | word | AI-06_engineeringValueMaxHigh | high word
0x03AD | 30942 | R | word | AI-06_engineeringValueMaxLow | low word
0x03AE | 30943 | R | word | AI-07_engineeringValueMaxHigh | high word
0x03AF | 30944 | R | word | AI-07_engineeringValueMaxLow | low word
0x03E0 | 30993 | R | word | AI-00_status | 0: normal, 1: burnout, 2: over range, 3: under range
0x03E1 | 30994 | R | word | AI-01_status | 0: normal, 1: burnout, 2: over range, 3: under range
0x03E2 | 30995 | R | word | AI-02_status | 0: normal, 1: burnout, 2: over range, 3: under range
0x03E3 | 30996 | R | word | AI-03_status | 0: normal, 1: burnout, 2: over range, 3: under range
0x03E4 | 30997 | R | word | AI-04_status | 0: normal, 1: burnout, 2: over range, 3: under range
0x03E5 | 30998 | R | word | AI-05_status | 0: normal, 1: burnout, 2: over range, 3: under range
0x03E6 | 30999 | R | word | AI-06_status | 0: normal, 1: burnout, 2: over range, 3: under range
0x03E7 | 31000 | R | word | AI-07_status | 0: normal, 1: burnout, 2: over range, 3: under range
0x02C0 | 40705 | R/W | word | AI-00_mode | 1: 4-20 mA, 2: 0-20 mA, 4: 4-20 mA burnout
0x02C0 | 40705 | R/W | word | AI-00_mode | 0: 0-10 V, 1: 0-20 mA, 2: 4-20 mA burnout, 3: 4-20 mA
0x02C1 | 40706 | R/W | word | AI-01_mode | 1: 4-20 mA, 2: 0-20 mA, 4: 4-20 mA burnout
0x02C1 | 40706 | R/W | word | AI-01_mode | 0: 0-10 V, 1: 0-20 mA, 2: 4-20 mA burnout, 3: 4-20 mA
0x02C2 | 40707 | R/W | word | AI-02_mode | 1: 4-20 mA, 2: 0-20 mA, 4: 4-20 mA burnout
0x02C2 | 40707 | R/W | word | AI-02_mode | 0: 0-10 V, 1: 0-20 mA, 2: 4-20 mA burnout, 3: 4-20 mA
0x02C3 | 40708 | R/W | word | AI-03_mode | 1: 4-20 mA, 2: 0-20 mA, 4: 4-20 mA burnout
0x02C3 | 40708 | R/W | word | AI-03_mode | 0: 0-10 V, 1: 0-20 mA, 2: 4-20 mA burnout, 3: 4-20 mA
0x02C4 | 40709 | R/W | word | AI-04_mode | 1: 4-20 mA, 2: 0-20 mA, 4: 4-20 mA burnout
0x02C4 | 40709 | R/W | word | AI-04_mode | 0: 0-10 V, 1: 0-20 mA, 2: 4-20 mA burnout, 3: 4-20 mA
0x02C5 | 40710 | R/W | word | AI-05_mode | 1: 4-20 mA, 2: 0-20 mA, 4: 4-20 mA burnout
0x02C5 | 40710 | R/W | word | AI-05_mode | 0: 0-10 V, 1: 0-20 mA, 2: 4-20 mA burnout, 3: 4-20 mA
0x02C6 | 40711 | R/W | word | AI-06_mode | 1: 4-20 mA, 2: 0-20 mA, 4: 4-20 mA burnout
0x02C6 | 40711 | R/W | word | AI-06_mode | 0: 0-10 V, 1: 0-20 mA, 2: 4-20 mA burnout, 3: 4-20 mA
0x02C7 | 40712 | R/W | word | AI-07_mode | 1: 4-20 mA, 2: 0-20 mA, 4: 4-20 mA burnout
0x02C7 | 40712 | R/W | word | AI-07_mode | 0: 0-10 V, 1: 0-20 mA, 2: 4-20 mA burnout, 3: 4-20 mA
0x02E0 | 40737 | R/W | word | AI-00_burnoutValueHigh | high word
0x02E1 | 40738 | R/W | word | AI-00_burnoutValueLow | low word
0x02E2 | 40739 | R/W | word | AI-01_burnoutValueHigh | high word
0x02E3 | 40740 | R/W | word | AI-01_burnoutValueLow | low word
0x02E4 | 40741 | R/W | word | AI-02_burnoutValueHigh | high word
0x02E5 | 40742 | R/W | word | AI-02_burnoutValueLow | low word
0x02E6 | 40743 | R/W | word | AI-03_burnoutValueHigh | high word
0x02E7 | 40744 | R/W | word | AI-03_burnoutValueLow | low word
0x02E8 | 40745 | R/W | word | AI-04_burnoutValueHigh | high word
0x02E9 | 40746 | R/W | word | AI-04_burnoutValueLow | low word
0x02EA | 40747 | R/W | word | AI-05_burnoutValueHigh | high word
0x02EB | 40748 | R/W | word | AI-05_burnoutValueLow | low word
0x02EC | 40749 | R/W | word | AI-06_burnoutValueHigh | high word
0x02ED | 40750 | R/W | word | AI-06_burnoutValueLow | low word
0x02EE | 40751 | R/W | word | AI-07_burnoutValueHigh | high word
0x02EF | 40752 | R/W | word | AI-07_burnoutValueLow | low word


ioLogik R1241 Modbus Address and Register Map

Address (hex) | Register (decimal) | Access | Type | Parameter Name | Description
0x04A0 | 41185 | R/W | word | AO-00_rawValue |
0x04A1 | 41186 | R/W | word | AO-01_rawValue |
0x04A2 | 41187 | R/W | word | AO-02_rawValue |
0x04A3 | 41188 | R/W | word | AO-03_rawValue |
0x04C0 | 41217 | R/W | word | AO-00_rawValuePowerOn |
0x04C1 | 41218 | R/W | word | AO-01_rawValuePowerOn |
0x04C2 | 41219 | R/W | word | AO-02_rawValuePowerOn |
0x04C3 | 41220 | R/W | word | AO-03_rawValuePowerOn |
0x04E0 | 41249 | R/W | word | AO-00_rawValueSafeMode |
0x04E1 | 41250 | R/W | word | AO-01_rawValueSafeMode |
0x04E2 | 41251 | R/W | word | AO-02_rawValueSafeMode |
0x04E3 | 41252 | R/W | word | AO-03_rawValueSafeMode |
0x0500 | 41281 | R/W | word | AO-00_mode | 0: 0-10 V, 1: 0-20 mA, 2: 4-20 mA
0x0501 | 41282 | R/W | word | AO-01_mode | 0: 0-10 V, 1: 0-20 mA, 2: 4-20 mA
0x0502 | 41283 | R/W | word | AO-02_mode | 0: 0-10 V, 1: 0-20 mA, 2: 4-20 mA
0x0503 | 41284 | R/W | word | AO-03_mode | 0: 0-10 V, 1: 0-20 mA, 2: 4-20 mA